• magic_lobster_party@kbin.social
    link
    fedilink
    arrow-up
    11
    arrow-down
    1
    ·
    edit-2
    7 months ago

    I’ve seen code that look like this:

    int delay = 15 * 60; // 10 minutes

    Even if the comment was on the same line someone forgot to update it. People just ignore comments.

    Better solution is to write (in C#):

    TimeSpan delay = TimeSpan.FromMinutes(15)

    Much more obvious what the code actually means.

    • 18107@aussie.zone
      link
      fedilink
      arrow-up
      7
      arrow-down
      1
      ·
      7 months ago

      A better comment would be delay in seconds as that is the one thing not obvious from glancing at the code.

      • magic_lobster_party@kbin.social
        link
        fedilink
        arrow-up
        12
        ·
        7 months ago

        Or just name the variable delaySeconds if you really want to store it as an int. Bonus is that every use of the variable perfectly communicates what it is.