Hey all,

My personal home-hosted server ran out of disk space and so went offline while I was away and I didn’t notice it for a week or two.

This meant that federation requests (or subscriptions requests) went offline and now most of the servers I’m federated with are lagging. I’m only getting updates from a couple.

Is there a way to trigger federated servers back to life so I get the subscription updates? Federation does seem to be working, given some servers seem to federate fine and this post was via federation and has worked.

  • BlackEco
    link
    fedilink
    11 month ago

    I had my Lemmy instance offline a few months ago (moved to another apartment) and it ended up solving itself out about a day after I set it up again. So patience is the solution?

    • SleepyBearOP
      link
      11 month ago

      I thought that, and in the past I’ve been off for a day or two and always caught up.

      This time I haven’t and it’s been a week or two since coming back online.

      • BlackEco
        link
        fedilink
        11 month ago

        Have you tried unsubscribing and re-subscribing to communities on instances that do not push updates? I think I did back then.

        • SleepyBearOP
          link
          11 month ago

          Yeah, I’ve tried that a couple of times too.

          And run through all the federation troubleshooting steps in the docs.

  • SleepyBearOP
    link
    11 month ago

    I worked out this was odd behavior on my OPNSense firewall NAT rules.

    For some reason some syncing worked (eg. beehaw.org) but new connections failed. I’m not sure why. Maybe established sessions were kept alive.

    Those rules haven’t changed in months and months, so I’ll chalk that up to “weirdness”.